唯一丸善で新品が買える状態になっていた,"Python Programming on WIN32"を注文したら以下のようなメールが来て,結局在庫がないらしい。Amazon.co.jpだと100,000円でマーケットプレイスに出品されている。いくらなんでもその価格はありえない。
ご注文いただいた商品に事故がありましたのでお知らせします。
以下、事故情報になります。
事故情報:
品切れで再版予定がございませんので、ご注文を解約させていただきます。
【ご注文内容】
注文日時:2008-07-xx xx:xx:xx
注文番号:9xxxxxxxxxxx
商品名:Python Programming on WIN32.
事故数量:1
2008/07/24
2008/07/19
FreeBSD 7.0-RにOpenLDAP 2.3とSamba 3.0.30をインストール
cvsup をインストール
pkg_add -r cvsup-without-gui
/usr/share/examples/cvsup から ports-supfile をコピーし、適宜編集。余計なportsは更新しないように設定し、cvsup を実行。
cvsup -g -L 2 ports-supfile
openldap-server-2.3.43 のインストール
cd /usr/ports/net/openldap23-server
make
make install
OpenSSL 0.9.8h のインストール
cd /usr/ports/security/openssl
make
make install
OpenSSH portable 5.0.P1 のインストール
cd /usr/ports/security/openssh-portable
make
make install
libiconv 1.11のインストール
デフォルトだとCP932からEUCJP-MSへのコード変換ができないので,ビルド時にEXTRA_PATCHESをあてるようにオプション指定。
cd /usr/ports/converters/libiconv
make
Options for libiconv 1.11_1
[X] EXTRA_ENCODINGS Include extra character sets
[X] EXTRA_PATCHES Apply patches to fix CP932 add EUCJP-MS
make install
Samba 3.0.30 のインストール
/var/db/ports/samba3/options で、WITH_LDAP=true とする(makeで選択メニューが表示される)。
cd /usr/ports/net/samba3
make
make install
Sambaの認証をLDAPで行うためのツール、smbldap-tools-0.9.5 をインストール
cd /usr/ports/net/smbldap-tools
make
make install
nss_ldap と pam_ldap は packages からインストール
pkg_add -r nss_ldap
pkg_add -r pam_ldap
slapd_owner="DEFAULT"を設定しないと、boot 時にハングするので要注意。
slapd_enable="YES"
slapd_flags='-h "ldapi://%2fvar%2frun%2fopenldap%2fldapi/ ldap://0.0.0.0/"'
slapd_sockets="/var/run/openldap/ldapi"
slapd_owner="DEFAULT"
samba_enable="YES"
ドメインは使わない設定。
charset = CP932
unix charset = EUCJP-MS
display charset = EUCJP-MS
workgroup = LDAP
server string = samba %v
socket options = TCP_NODELAY SO_RCVBUF=8760 SO_SNDBUF=8760
passdb backend = ldapsam:ldap://localhost
ldapsam:trusted = yes
security = user
admin users = admin
log file = /var/log/samba/log.%m
load printers = no
disable spoolss = yes
os level = 35
preferred master = Yes
domain master = Yes
domain logons = no
ldap suffix = dc=example,dc=com
ldap machine suffix = ou=Computers
ldap user suffix = ou=Users
ldap idmap suffix = ou=Users
ldap group suffix = ou=Groups
ldap admin dn = cn=Manager,dc=example,dc=com
ldap ssl = no
ldap passwd sync = yes
host 127.0.0.1
base dc=example,dc=com
pam_filter objectclass=posixAccount
smbldap-populate でLDAPにsambaの認証に必要なエントリを追加。
Populating LDAP directory for domain LDAP (S-1-5-21-4022882558-1189897452-XXXXXXXXXX)
(using builtin directory structure)
entry dc=example,dc=com
entry ou=Users,dc=example,dc=com
entry ou=Groups,dc=example,dc=com
entry ou=Computers,dc=example,dc=com
entry ou=Users,dc=example,dc=com
entry uid=root,ou=Users,dc=example,dc=com
entry uid=nobody,ou=Users,dc=example,dc=com
entry cn=Domain Admins,ou=Groups,dc=example,dc=com
entry cn=Domain Users,ou=Groups,dc=example,dc=com
entry cn=Domain Guests,ou=Groups,dc=example,dc=com
entry cn=Domain Computers,ou=Groups,dc=example,dc=com
entry cn=Administrators,ou=Groups,dc=example,dc=com
entry cn=Account Operators,ou=Groups,dc=example,dc=com
entry cn=Print Operators,ou=Groups,dc=example,dc=com
entry cn=Backup Operators,ou=Groups,dc=example,dc=com
entry cn=Replicators,ou=Groups,dc=example,dc=com
entry sambaDomainName=LDAP,dc=example,dc=com Updating it...
Please provide a password for the domain root:
Changing UNIX and samba passwords for root
New password:
Retype new password:
UNIX/Linuxのパスワードファイルを migrate。-aオプションは sambaSamAccount objectClassを追加する。
smbldap-migrate-unix-accounts -P passwd -a
smbpasswd を importするのは、自前の ruby-net-ldap を利用したスクリプトで行った。
smbcllient //server//foo password を試したとき NT_STATUS_UNSUCCESSFUL が発生して samba に foo ユーザで接続できなかったが、
auth/auth.c:check_ntlm_password(319)
check_ntlm_password: Authentication for user [foo] -> [foo] FAILED with error NT_STATUS_UNSUCCESSFUL
LDAP で ou=Groups に foo ユーザのグループのエントリを定義していなかったことが原因だった。数時間もはまった。
skapcat で dump したときに,
bdb_db_open: Warning - No DB_CONFIG file found in directory /var/db/openldap-data: (2)
Expect poor performance for suffix dc=example,dc=com.
という warning メッセージが表示された。
/usr/local/etc/openldap/DB_CONFIG.example から /var/db/openldap-data/DB_CONFIG にサンプル設定ファイルをコピーしておいた。
pkg_add -r cvsup-without-gui
/usr/share/examples/cvsup から ports-supfile をコピーし、適宜編集。余計なportsは更新しないように設定し、cvsup を実行。
cvsup -g -L 2 ports-supfile
openldap-server-2.3.43 のインストール
cd /usr/ports/net/openldap23-server
make
make install
OpenSSL 0.9.8h のインストール
cd /usr/ports/security/openssl
make
make install
OpenSSH portable 5.0.P1 のインストール
cd /usr/ports/security/openssh-portable
make
make install
libiconv 1.11のインストール
デフォルトだとCP932からEUCJP-MSへのコード変換ができないので,ビルド時にEXTRA_PATCHESをあてるようにオプション指定。
cd /usr/ports/converters/libiconv
make
Options for libiconv 1.11_1
[X] EXTRA_ENCODINGS Include extra character sets
[X] EXTRA_PATCHES Apply patches to fix CP932 add EUCJP-MS
make install
Samba 3.0.30 のインストール
/var/db/ports/samba3/options で、WITH_LDAP=true とする(makeで選択メニューが表示される)。
cd /usr/ports/net/samba3
make
make install
Sambaの認証をLDAPで行うためのツール、smbldap-tools-0.9.5 をインストール
cd /usr/ports/net/smbldap-tools
make
make install
nss_ldap と pam_ldap は packages からインストール
pkg_add -r nss_ldap
pkg_add -r pam_ldap
/etc/rc.conf
slapd_owner="DEFAULT"を設定しないと、boot 時にハングするので要注意。
slapd_enable="YES"
slapd_flags='-h "ldapi://%2fvar%2frun%2fopenldap%2fldapi/ ldap://0.0.0.0/"'
slapd_sockets="/var/run/openldap/ldapi"
slapd_owner="DEFAULT"
samba_enable="YES"
/usr/local/etc/smb.conf
ドメインは使わない設定。
charset = CP932
unix charset = EUCJP-MS
display charset = EUCJP-MS
workgroup = LDAP
server string = samba %v
socket options = TCP_NODELAY SO_RCVBUF=8760 SO_SNDBUF=8760
passdb backend = ldapsam:ldap://localhost
ldapsam:trusted = yes
security = user
admin users = admin
log file = /var/log/samba/log.%m
load printers = no
disable spoolss = yes
os level = 35
preferred master = Yes
domain master = Yes
domain logons = no
ldap suffix = dc=example,dc=com
ldap machine suffix = ou=Computers
ldap user suffix = ou=Users
ldap idmap suffix = ou=Users
ldap group suffix = ou=Groups
ldap admin dn = cn=Manager,dc=example,dc=com
ldap ssl = no
ldap passwd sync = yes
/usr/local/etc/nss_ldap.conf
host 127.0.0.1
base dc=example,dc=com
pam_filter objectclass=posixAccount
smbldap-populate でLDAPにsambaの認証に必要なエントリを追加。
Populating LDAP directory for domain LDAP (S-1-5-21-4022882558-1189897452-XXXXXXXXXX)
(using builtin directory structure)
entry dc=example,dc=com
entry ou=Users,dc=example,dc=com
entry ou=Groups,dc=example,dc=com
entry ou=Computers,dc=example,dc=com
entry ou=Users,dc=example,dc=com
entry uid=root,ou=Users,dc=example,dc=com
entry uid=nobody,ou=Users,dc=example,dc=com
entry cn=Domain Admins,ou=Groups,dc=example,dc=com
entry cn=Domain Users,ou=Groups,dc=example,dc=com
entry cn=Domain Guests,ou=Groups,dc=example,dc=com
entry cn=Domain Computers,ou=Groups,dc=example,dc=com
entry cn=Administrators,ou=Groups,dc=example,dc=com
entry cn=Account Operators,ou=Groups,dc=example,dc=com
entry cn=Print Operators,ou=Groups,dc=example,dc=com
entry cn=Backup Operators,ou=Groups,dc=example,dc=com
entry cn=Replicators,ou=Groups,dc=example,dc=com
entry sambaDomainName=LDAP,dc=example,dc=com Updating it...
Please provide a password for the domain root:
Changing UNIX and samba passwords for root
New password:
Retype new password:
UNIX/Linuxのパスワードファイルを migrate。-aオプションは sambaSamAccount objectClassを追加する。
smbldap-migrate-unix-accounts -P passwd -a
smbpasswd を importするのは、自前の ruby-net-ldap を利用したスクリプトで行った。
注記
smbcllient //server//foo password を試したとき NT_STATUS_UNSUCCESSFUL が発生して samba に foo ユーザで接続できなかったが、
auth/auth.c:check_ntlm_password(319)
check_ntlm_password: Authentication for user [foo] -> [foo] FAILED with error NT_STATUS_UNSUCCESSFUL
LDAP で ou=Groups に foo ユーザのグループのエントリを定義していなかったことが原因だった。数時間もはまった。
skapcat で dump したときに,
bdb_db_open: Warning - No DB_CONFIG file found in directory /var/db/openldap-data: (2)
Expect poor performance for suffix dc=example,dc=com.
という warning メッセージが表示された。
/usr/local/etc/openldap/DB_CONFIG.example から /var/db/openldap-data/DB_CONFIG にサンプル設定ファイルをコピーしておいた。
2008/07/10
FreeBSD 7.0-RでportsからBIND 9.5.0-P1をインストール
BINDの脆弱性が明らかになった一昨日の時点ではportsからインストールできなかったけど、今日cvsupしたらportsでも対応してた。
cvsup -g 2 -L 2 ports-supfile
cd /usr/ports/dns/bind95
make
make deinstall
make reinstall
cvsup -g 2 -L 2 ports-supfile
cd /usr/ports/dns/bind95
make
make deinstall
make reinstall
2008/07/08
東北新幹線にモバイルSuicaで乗ってみた
JR東海のEX-ICは何回か利用したけど、最近東日本の新幹線に乗る機会がなかったので初めて試した。
予約・変更はPC用のサイトとケータイからとどちらからでもできる。
東海道新幹線と違うのは、予約した切符データをダウンロードしてFelicaに書き込む必要がある点(受取と呼ばれる。これがクセモノ)。
受取りした後に予約変更する場合は"預け入れ"をしてから変更してまた"受取り"をする必要がある(え?)。
何回もケータイで予約変更を繰り返しているとかなりパケット代がかかるのが難点。今月はパケットパック(ドコモの)に入っていないのでモバイルSuicaへアクセスしているだけで500円ぐらいパケット料金とられた。通話料金は会社請求できるけど、パケット代は自腹なのでかなりイタイ。
東海道新幹線は車内の検札がまだあるので、改札でケータイをタッチしたときに列車番号と席番号を書いた"ICご利用表(領収書代わりになる)"が出てくるけど、JR東日本だとなんにも出てこないので拍子抜け。
で、予約した電車と車両、席がどこなのか確認するのがまた一苦労(車掌の端末にタッチするとすぐ確認できるらしい)。予約確定のときにメールで予約情報を送信してくれるか、画面メモ保存できるといいよなぁ。
行きの新幹線のチケットデータは改札から出たあと"使用済み"になって、帰りの切符を予約して受取りすると、自動的に預け入れされる。
領収書はモバイルSuicaのサイトでPDFで発行できるけど一回きり。ダウンロードに失敗したときはどうするんだろう?
いずれにしてもユーザビリティがいまひとつ。
予約・変更はPC用のサイトとケータイからとどちらからでもできる。
東海道新幹線と違うのは、予約した切符データをダウンロードしてFelicaに書き込む必要がある点(受取と呼ばれる。これがクセモノ)。
受取りした後に予約変更する場合は"預け入れ"をしてから変更してまた"受取り"をする必要がある(え?)。
何回もケータイで予約変更を繰り返しているとかなりパケット代がかかるのが難点。今月はパケットパック(ドコモの)に入っていないのでモバイルSuicaへアクセスしているだけで500円ぐらいパケット料金とられた。通話料金は会社請求できるけど、パケット代は自腹なのでかなりイタイ。
東海道新幹線は車内の検札がまだあるので、改札でケータイをタッチしたときに列車番号と席番号を書いた"ICご利用表(領収書代わりになる)"が出てくるけど、JR東日本だとなんにも出てこないので拍子抜け。
で、予約した電車と車両、席がどこなのか確認するのがまた一苦労(車掌の端末にタッチするとすぐ確認できるらしい)。予約確定のときにメールで予約情報を送信してくれるか、画面メモ保存できるといいよなぁ。
行きの新幹線のチケットデータは改札から出たあと"使用済み"になって、帰りの切符を予約して受取りすると、自動的に預け入れされる。
領収書はモバイルSuicaのサイトでPDFで発行できるけど一回きり。ダウンロードに失敗したときはどうするんだろう?
いずれにしてもユーザビリティがいまひとつ。
2008/07/05
LDAP Authentication Plugin for Rails
RailsでLDAP認証を行うためのプラグイン。
http://www.noitulove.ch/ldap-authentication-plugin-for-rails/
http://www.noitulove.ch/ldap-authentication-plugin-for-rails/
ラベル:
LDAP,
Ruby on Rails
2008/07/03
Mzoneへのログインが便利になった
cookieの有効期限を最大30日に設定できて、ユーザ名とパスワードを毎回入力しなくてもアクセスポイントに接続できるようになった。
かんたんログイン機能、自動ログイン機能
かんたんログイン機能、自動ログイン機能
登録:
投稿 (Atom)